could not execute command 'lessc' odoo 9.0

Well ... odoo installed properly and running well on local server. However after creating a data base and successfully logging in, the odoo appearance got weird error message informed could not execute command 'lessc' spending couple hours for googling and various suggestion did not work properly
Understanding the error
'lessc' is the clue whats the error, odoo depending very much one node-less ubuntu and red-hat have package named node-less but gentoo dont't have it. When installing nodejs we have nmp package merged bu USE flag. Use this to install less package
# npm install -g less
# ls /usr/bin
...............
lessc -> ../lib64/node_modules/less/bin/lessc
..............
Restart odoo-server and check with your web ... the error msg will be gone
That's it

Posted in . Bookmark the permalink. RSS feed for this post.

About Me

My photo

a Man who do like The God's Humor, Linux Lover, Android Fellow.

Google+ Followers

Search

Swedish Greys - a WordPress theme from Nordic Themepark. Converted by LiteThemes.com.